LibreOffice Writer Avanzado

De WikiSalud
Saltar a: navegación, buscar

Ver: LibreOffice Writer Intermedio

Contenido

Auto texto

Crea, edita o inserta AutoTexto. Puede almacenar texto formateado, texto con imágenes, tablas y campos como AutoTexto

Barra de menú → Editar → Autotexto

barra de menu, editar
Observará lo siguiente
Ventana de autotextothumb
  • Nombre:muestra el nombre de la entrada de AutoTexto seleccionada. Si ha seleccionado texto en el documento, escriba el nombre de la entrada nueva de AutoTexto, haga clic en el botón AutoTexto y, a continuación, elija Nuevo.
  • Abreviatura:muestra la abreviatura de la entrada de AutoTexto seleccionada. Si desea crear una entrada nueva de AutoTexto, escriba la combinación de teclas que desee usar para la entrada.
  • Listado:muestra las categorías de Texto automático. Para ver las entradas de Texto automático en una categoría, pulse dos veces sobre la categoría o pulse sobre el signo más (+) que hay delante de la categoría. Para incluir una entrada de Texto automático en el documento, seleccione la entrada de la lista y pulse Insertar.
  • Insertar: inserta el Texto automático seleccionado en el documento.
  • Cerrar: cierra el diálogo y guarda todos los cambios.
  • AutoTexto: haga clic para mostrar comandos adicionales de AutoTexto, por ejemplo para crear una entrada de AutoTexto a partir de un texto seleccionado en el documento.
  • Nuevo: crea una nueva entrada de AutoTexto a partir de una selección hecha en el documento. La entrada se agrega a la categoría de AutoTexto seleccionada.
  • Nuevo (sólo texto): crea una nueva entrada de AutoTexto sólo a partir del texto de la selección hecha el documento. Las imágenes, las tablas y otros objetos no se incluyen.
  • Copiar: copia el AutoTexto seleccionado en el portapapeles.
  • Reemplazar: sustituye el contenido de la entrada de AutoTexto marcada por la selección hecha en el documento.
  • Cambiar nombre: abre el diálogo Cambiar nombre de Autotexto, en el que se puede cambiar el nombre de la entrada seleccionada de Autotexto.
  • Borrar: borra el elemento o elementos seleccionados tras la confirmación.
  • Editar: abre la entrada seleccionada de AutoTexto para editarla en otro documento. Efectúe los cambios pertinentes, elija Archivo → Guardar módulo de texto y, a continuación, elija Archivo → Cerrar.
  • Macro : abre el diálogo Asignar macro, en el que se puede adjuntar una macro a la entrada seleccionada de Autotexto.
  • Importar: abre un diálogo donde puede seleccionar el documento o la plantilla que contiene las entradas de AutoTexto que desee importar.
  • Áreas: cambia el nombre de las categorías de AutoTexto, las agrega o las borra.
  • Ruta: muestra la ruta del directorio donde se almacena la categoría seleccionada de AutoTexto. Si desea crear una categoría de AutoTexto, seleccione la ubicación donde almacenar los archivos de la categoría.
  • Guardar vínculos relativamente: esta zona se utiliza para configurar el modo en que LibreOffice inserta vínculos en el directorio de Texto automático.
  • En el sistema de archivos: los vínculos con los directorios de AutoTexto en el equipo son relativos.
  • En Internet: los vínculos con los archivos en Internet son relativos.
  • Mostrar previsualización:abre o cierra una vista previa de la entrada seleccionada de AutoTexto.
  • Previsualización: muestra una vista preliminar de la entrada seleccionada de Texto automático.


Para crear autotexto

  • Si se trabaja con texto, seleccionar texto → colocar nombre del autotexto → elegir Mis autotexto
  • En autotexto elegir solo texto para trabajar
  • Observará que cuando se le coloca un nombre, se le activa una abreviatura, que es un atajo para activar el autotexto.
  • Se puede aplicar Insertar o colocar en el la abreviatura con F3 para activar el autotexto

Si se desea agregar una imagen

Elegir autotexto, editar

Menú autotexto editar

mostrará otro archivo, en ella se le agregará imágenes, tabla, etc. Grabar y ejecutar autotexto con la abrevitura + F3

Para Eliminar autotexto

  • En la ventana de autotexto, seleccionar el nombre del autotexto, elegir autotexto mostrará listado de seleccion Eliminar.

Operaciones en diferentes tablas

Para trabajar con operaciones entre diferentes tablas :

Crear las tablas ( las necesarias), como ejemplo utilizaremos dos tablas

Tabla1

Tabla de ejemplo

Donde la tabla de los datos le llamaremos Tabla1

Para la Tabla 2 utilizaremos formula =<Tabla1.B1>+<Tabla1.B2> +<Tabla1.B3> que indica la operación de las filas.
Writer utiliza los símbolos de mayor y menor para delimitar la formula e igual como toda formula estará acompañada por el símbolo ( = ).

Como Resultado

Tabla2

Tabla de resultados

Podemos trabajar con tantas tablas, las que se necesiten y utilizar formulas para realizar las operaciones ya sean : Operaciones Básicas, operadores, operaciones básicas del submenú, funciones estadísticas, trigonométricas.

La ubicación del resultado de las formulas estará en la fila o celda donde requiera cualquier operación.

El nombre de Tabla1 o tabla2 Writer por defecto las enumera cuando utiliza las operaciones para identificarlas.

tabla de resultado mostrando operaciones

Fórmulas y diagramas de flujo

Fórmulas

Para aplicar fórmulas Barra de menú → Fórmula o la de la tecla F2

Se puede insertar una fórmula en una celda de la tabla. Sitúe el cursor en una celda de la tabla o en el lugar del documento donde desea que aparezca el resultado. Haga clic en el símbolo Fórmula y elija una fórmula en el submenú.

(thumbnail)
Funciones

Aparece la fórmula en la línea de entrada. Para especificar el área de celdas de una tabla selecciónelas con el ratón. Las referencias correspondientes a las celdas aparecen en la línea de entrada. Escriba parámetros adicionales, según sea necesario, y pulse Aplicar para confirmar la entrada.

Opciones de fórmulas

Se puede aplicar operaciones cálculo, funciones, operadores, para realizar operaciones dentro de la tablas o tablas.

(thumbnail)
Barra de Fórmula


Diagramas de flujo

Para crear un diagrama de flujo:

  1. Seleccione en la barra de Dibujo Diagrama de flujo .
    Barra de Dibujo,Diagrama de Flujo
  2. Arrastre una forma al área de trabajo.
  3. Para agregar más formas, repita los últimos pasos.
  4. Abra la barra de herramientas Conectores en la barra de herramientas Dibujo y seleccione una línea de conexión.
  5. Desplace el puntero al borde de una forma, de modo que aparezcan los puntos de conexión y elija línea para unir.
  6. Pulse sobre un punto de conexión, arrastre hasta un punto de conexión en otra forma y suelte el botón.
  7. Para agregar más gráficos de flujo y conectores, repita los últimos pasos.
  8. Ya ha creado el esquema básico del diagrama de flujo.
    (thumbnail)
    Diagrama de Flujo

Para agregar texto a las formas del diagrama de flujo

  • Hacer lo siguiente:
  1. Haga doble clic en la forma, y escriba o pegue el texto.
  2. Haga clic en el icono Texto de la barra Dibujo icono de textoy arrastre un objeto de texto encima de la forma. Escriba o pegue el texto en el objeto de texto.

Para incorporar un relleno de color a una forma:

  • Seleccione la forma y escoge Formato - Relleno.
  • Seleccione Colores y haga clic en uno de los colores.
    (thumbnail)
    Diagrama de Flujo con relleno

Control de cambios

Se trata de que todas las modificaciones que se realizan en un documento se queden guardadas en el mismo, de manera que en cualquier momento podemos acceder a una versión anterior. Además se puede ver en todo momento las modificaciones que se han realizado, cuando se han realizado,se puede añadir incluso anotaciones, que nos pueden recordar porque hicimos determinado cambio en el documento.

Para acceder Barra de menú → Editar → elegir cambio
Barra de menu,editar,cambio
Al aplicar la opción Grabar, a partir de ese preciso instante cualquier cambio que se realice quedará grabado,es importante marcar también la opción “Mostrar”, para tener un mayor control sobre los cambios realizados, con lo que el menú quedará
Barra de menu,editar,cambio
De esta manera conforme se vaya haciendo cambios el documento, tomara una forma similar a la que se puede ver
(thumbnail)
Documento con cambios
Donde se puede observar que cuando se borra algo en el documento no se borra, sino que queda tachado, cuando se inserta queda subrayado.

La forma de ver los cambios se puede modificar en Herramientas → Opciones → LibreOffice Writer → Cambios

(thumbnail)
Ventana de cambio

El color del cambio puede ser por usuario, que en documentos en los que tienen que intervenir diferentes autores, es una solución muy interesante para evitar conflictos. También se puede seleccionar que sea fijo como es el caso que aparece en la imagen. Además se puede ver quien y cuando se realizó un determinado cambio, con solo pasar el cursor por encima del texto modificado:

(thumbnail)
Documento modificado

Cuando se esta conforme con un cambio se puede aceptar o rechazar, con solo pulsar el botón derecho del ratón que mostrará el siguiente menú contextual

(thumbnail)
Menú contextual

Si en un momento determinado, se quiere ver como queda el documento, pero sin aceptar o rechazar las modificaciones, o bien se requiere imprimirlo, simplemente se quita la marca en el menú “Cambios” donde dice “Mostrar”. Una vez se haya impreso el documento, vuelves a marcar “Mostrar” y a seguir trabajando.

Se puede guardar varias versiones de un mismo documento, con la posibilidad de cargar el que se necesite en cualquier momento. Para ello, en el menú se selecciona Archivo → Versiones para ir guardando diferentes versiones del documento, que se pueden recuperar según la conveniencia.

Capítulos e índice de capítulos

Capítulos

Se puede modificar la jerarquía del encabezado o asignar un nivel en la jerarquía a un estilo de párrafo personalizado. También se puede añadir numeración de capítulos y de secciones a los estilos de párrafo del encabezado. De forma predeterminada, el estilo de párrafo "Encabezado 1" ocupa la parte superior de la jerarquía de numeración. Para agregar numeración automática a un estilo de encabezado

Seleccione Herramientas → Esquema de numeración y haga clic en la ficha Numeración .

  • En el cuadro Estilo de párrafo , seleccione el estilo de encabezado al que desee agregar números de capítulos.
  • En el cuadro Números, seleccione el estilo de numeración que desea utilizar y, a continuación, haga clic en Aceptar.
(thumbnail)
Ventana de esquema de numeración

Para eliminar la numeración de esquema automática de un párrafo de encabezado

  • Haga clic en el comienzo del texto del párrafo de encabezado, después del número.
  • Pulse la tecla Retroceso para eliminar el número.

Para utilizar un estilo de párrafo personalizado como encabezado

  • Seleccione Herramientas → Esquema de numeración y haga clic en la ficha Numeración .
  • Seleccione el estilo personalizado en el cuadro Estilo de párrafo.
  • Haga clic en el nivel de encabezado que desee asignar al estilo de párrafo personalizado en la lista Nivel.
  • Pulse en Aceptar.


Índice de capítulos

Para los documentos largos que se necesiten enumerar, se hace con numeración automática. En writer se resuelve con Estilos que ya vienen predefinidos, unos estilos (Encabezado 1, Encabezado 2, etc...) que se pueden usar directamente o redefinir de manera personalizada.

  • Abrir la ventana del estilista pulsando F11 o mediante la barra de menú → Formato → Estilo y formato. En la lista de estilos seleccionamos uno para modificar, y en el menú contextual (pulsando el botón derecho del ratón) tenemos la opción de Modificar, donde se podra cambiar cualquier atributo del estilo.
(thumbnail)
Ventana de Estilo de párrafo

Ventana a modificar el estilo párrafo, Esquema y numeración

(thumbnail)
Ventana de Estilo de párrafo,Encabezado

Para Enumerar capítulos

  • Barra de menú → Herramientas → Esquema de numeración, donde para cada uno de los niveles de esquema de nuestro documento, asignaremos el estilo correspondiente (si hemos utilizado los predefinidos, ya estarán correctamente coordinados), y personalizados con qué estilo, separadores, primer número, etc.
  • Aceptar

Capítulos en Encabezados y pie de página

Para que aparezca el nombre del capítulo, el número o ambos en el encabezado de página, basta con abrir el diálogo de Campos mediante el menú Insertar → Campos → Otros. En el cuadro de diálogo, seleccionamos la pestaña Documento, como Tipo de campo seleccionamos Capítulo y en la lista Formato podremos seleccionar la apariencia deseada. También podremos seleccionar el Nivel del cual deseamos tomar los datos.
(thumbnail)
Campos

Indices y tabla de contenido

Barra de menú Insertar → Índice → Índices. En la pestaña Índice del diálogo emergente, seleccionaremos el título del índice, tipo de índice (en el caso que estamos tratando, Índice de contenido) y el número de niveles que deseamos que aparezcan en el índice.

En la pestaña Entradas del diálogo, para cada nivel, se decidirá la estructura del índice. Para ello, Writer nos provee de una muestra constituida por unos botones con pequeños cuadros de texto vacíos entre ellos; apuntando con el cursor encima de ellos, veremos que simbolizan el número de capítulo, el nombre del capítulo, el número de página, etc. También se dispone de un botón Hiperenlace que nos permitirá insertar vínculos en la tabla de contenido para que nuestro documento sea navegable desde el índice. Simplemente debemos poner el punto de inserción en los cuadritos de texto en la posición deseada para inicio y fin del vínculo, y pulsando el botón Hiperenlace para cada uno de ellos, nos definirá el vínculo para la entrada del índice. Podemos ver la apariencia que tendrá activando la casilla Previsualización.

(thumbnail)
Indice, Entradas

Vista de Esquema

Los beneficios de trabajar con estilos de encabezado en Writer,dispone de las funcionalidades que la vista Esquema proporciona. Abrir la ventana del Navegador pulsando F5 o mediante la barra de menú Editar → Navegador. El Navegador es una herramienta exclusiva de Writer que nos permitirá, entre otras cosas:

  • Desplazar rápidamente en documentos largos, para ello simplemente, hacer doble clic en el encabezado deseado.
  • Reorganizar la estructura de nuestro documento, cambiando los niveles de capítulos y su posición relativa, al modo de la vista Esquema, seleccionando el encabezado deseado y pulsando sobre los botones del propio navegador: Subir capítulo un nivel, Bajar capítulo un nivel, Aumentar nivel y Disminuir nivel. Pulsándolos como incluso se modifican los estilos de encabezado aplicados para adecuarse al nivel requerido.
(thumbnail)
Navegador

Hiperenlaces

Es un elemento html que permiten indicar zonas de texto e imágenes dentro de las paginas Web, teniendo una ruta o unión con otras paginas web.

Writer también permite insertar en un documento de texto los llamados hipervínculos o hiperenlaces. Estos pueden consistir en palabras, símbolos o incluso ilustraciones del documento, que han sido dotados de la posibilidad de abrir ante el lector en pantalla otros documentos e incluso programas, ya sea del disco duro de su misma computadora, de una usb, o de sitios de Internet, con tan solo un clic del mouse sobre el hipervínculo. Para emplear esta opción, que es de amplio uso en páginas web, se debe seleccionar primero la palabra o elemento del texto inicial que se usará como hipervínculo en este caso cree un subtitulo corto para cada cuadro de texto.

  • Elegir o seleccionar el texto o imagen
  • barra de menú → Insertar → Hiperenlace o icono aparecerá lo siguiente Icono de hiperenlace


(thumbnail)
Ventana de hiperenlace

Dependiendo de la ubicación del archivo de destino del salto que genera el hipervínculo, se usa el botón de la parte superior

Icono de abrir archivo


Si el archivo se encuentra en el mismo PC, o en una USB o en Internet, y el de abajo si se desea saltar a una sección anterior o posterior del mismo documento en que se está trabajando (esto último es útil para generar índices activos para documentos que se desea trabajar en la pantalla de la computadora).

Esta posibilidad de agregación de hipervínculos, si bien es útil solamente para el modo de trabajo del documento en pantalla (no impreso), tiene la ventaja de facilitar el acceso directo a múltiples otras fuentes que pueden ofrecer información más completa sobre el tema de un documento, dotándolo así de la posibilidad de una lectura no lineal o multidimensional

Protección con contraseñas

Para proteger con contraseña un documento hacer:

  • Seleccionar el archivo y abrirlo
  • Menú Archivo → Guardar como, mostrará lo siguiente ventana
    (thumbnail)
    Protección de contraseña
  • Despues de colocarle el nombre del archivo y elegir con contraseña, aparecerá la siguiente ventana
    (thumbnail)
    Ventana Protección de contraseña
  • Elegir contraseña y confirme la contraseña
  • Más opciones: también podemos compartir el documento mediante el botón de “Más Opciones”. Compartir el archivo en modo sólo lectura o no mediante la casilla “Abrir documento sólo para lectura”.
    (thumbnail)
    Protección de contraseña
  • Aceptar.

La comprobación es sencilla, abrir de nuevo el documento de texto y confirmar que nos pide la contraseña.

Combinación de correspondencia

Se inicia el Asistente para combinar correspondencia para crear cartas modelo o enviar mensajes de correo electrónico a muchos destinatarios.

Elegir Barra de menú →  Herramientas → Asistente para combinar correspondencia.

Asistente de correspondencia

La Ventana Principal de Combinación de correspondencia esta formada por:

Documento inicial

Se especifica el documento que desea emplear como base para el documento de combinar correspondencia.

  • Usar el documento actual: Se utiliza el documento de Writer actual como base del documento de combinar correspondencia.
  • Crear un documento nuevo: Crea un documento de Writer para utilizarse con la combinación de correspondencia.
  • Comenzar a partir del documento existente:Seleccione un documento de Writer para utilizarlo como base del documento de combinar correspondencia.
  • Comenzar a partir de plantilla:Seleccione la plantilla con la que desea crear el documento de combinar correspondencia.

Seleccione el documento.

Tipo de Documento

Especifique el tipo de documento para combinar correspondencia que se creará.

  • Carta:crea un documento de combinar correspondencia que se puede imprimir.
  • Mensaje de correo electrónico: crea documentos para combinar correspondencia que puede enviar en un mensaje o adjunto de correo electrónico.

Direcciones

Especifica los destinatarios del documento de combinar correspondencia, así como el diseño del bloque de direcciones.

  • Seleccionar lista de direcciones: abre el diálogo Seleccionar lista de direcciones, en el que se puede elegir un origen de datos para las direcciones, agregar direcciones o escribir en una lista de direcciones nueva.
  • Este documento contendrá un bloque de direcciones: agrega un bloque de direcciones al documento de combinar correspondencia.
  • Seleccione el diseño de bloque de direcciones que desea utilizar.
  • Suprimir líneas con campos vacíos: se habilita esta opción para excluir de la dirección las líneas vacías.
  • Más:abre el diálogo Seleccionar libreta de direcciones.
  • Asignar campos. abre el diálogo Asignar campos.
  • Botones de navegación: utilice los botones de navegación para obtener una vista previa de la información del registro de datos anterior o siguiente.

Saludo

Especifique las propiedades del saludo.! Si la base de datos de combinar correspondencia contiene información acerca del género, se pueden especificar saludos diferentes según el género que tenga el destinatario.

Ajustar diseño

Especifique la posición de los bloques de direcciones y los saludos en los documentos.

Editar Documento Examine las vistas previas de documentos, excluya destinatarios concretos y edite el documento principal.

Personalizar Documento Edite documentos de cada destinatario.

Guardar, imprimir, enviar Especifica las opciones de salida de los documentos de combinar correspondencia


Para trabajar con combinación de correspondencia seguir lo siguiente:

  1. Crear una tabla con registros en calc, como una pequeña base de datos.
    (thumbnail)
    Ejemplo de base de datos
  2. Guardar la base de datos en Calc archivo → guardar ,luego para la base de datos elegir, Barra de menú→ Archivo→ Nuevo→ Base de datos
    (thumbnail)
    Nuevo,Base de datos
  3. Elegir conectar con una base de datos existente y seleccionar hoja de cálculo
    Paso 1 del asistente

  4. Buscar y agregar la tabla de base de datos creada. Siguiente. Buscar en el botón Examinar en la carpeta o lugar donde se haya guardado (Disco duro, usb, carpeta personal).
    Paso 2 del asistente

  5. Guardar y finalizar
    Paso 3 del asistente
  6. Abrir un documento en writer y editar el documento donde se combinará la base de datos
  7. Ejecutar o presionar F4, todo lo que se ejecuta se llama origen de datos, mostrará lo siguiente:
    Ventana de combinación bases de dato, writer

    A la izquierda del documento mostrará la base datos que sea creado y guardado y la derecha muestra el resumen de la base datos junto los campos que están en columna y sus respectivos registros que aparecen en filas.
    Dentro del documento tal como indica la imagen arrastramos el nombre del campo hacia la ubicación, se selecciona el campo en este ejemplo nombre_alumno y tomara todos los registros que contenga.
  8. Iniciar el asistente para combinar correspondencia para crear documentos como cartas o enviar mensajes de correo electrónico a muchos destinatarios.
    También barra de menú → herramientas → asistente para combinar correspondencia
    Seguir asistentes
    Asistente de correspondencia

  9. Guardar el documento combinado, paso 8
    Guardar o imprimir la correpondencia
  10. Finalizar
Nota: algunos pasos ya están hechos con anterioridad, por lo tanto pasar al paso 8 del asistente.
Herramientas personales
Espacios de nombres

Variantes
Acciones
Navegación
Herramientas