KWrite

De WikiSalud
Saltar a: navegación, buscar

Construccion.jpg

Contenido

Definición

El editor KWrite le permite crear fácilmente textos sencillos o listas. KWrite también puede utilizarse para reproducir con resaltado en color textos fuente en diversos lenguajes de programación o textos HTML para su posterior edición. KWrite es más que un simple editor de texto para KDE. Pretende ser un editor para programadores y ser considerado, al menos parcialmente, como alternativa a los editores más potentes. Puede usarse en conjunción con Konqueror para navegar entre archivos fuente de varios lenguajes de programación. KWrite también es útil si desea un sencillo editor de textos. Una de las principales características de KWrite es el coloreado de sintaxis según el lenguaje del archivo, incluyendo C/C++, Java™, Python, Perl, Bash, Modula 2, HTML y Ada.

Característica

  • Exportación a HTML
  • Bloqueo del modo de selección
  • Seguimiento de código
  • Marcadores
  • Resaltado de sintaxis
  • Posibilidad de elegir la codificación (pero no la detecta automáticamente, sino que usa siempre la predefinida del sistema al abrir un fichero, independientemente de su codificación)
  • Modo de selección de fin de línea según (Unix, Windows, Macintosh)
  • Autocompletado de palabras
  • Edición de archivos alojados en servidores remotos (FTP, Fish ).

Entradas del Menú Principal

Menú Archivo


(thumbnail)
Menú Archivo

  • Nuevo: Abre un documento nuevo. Si tiene otro documento abierto en ese instante se cerrará dándole la opción de guardar los cambios.
  • Abrir: Muestra un diálogo Abrir archivo estándar. Utilice la vista de selección de archivos para seleccionar el archivo que desee abrir, y pulse sobre Abrir para abrirlo. Puede encontrar más información sobre el diálogo Abrir archivo de KDE en la guía de usuario de KDE.
  • Abrir Reciente: Éste es un acceso rápido para abrir los últimos documentos guardados. Pulsar sobre este elemento abre una lista al lado del menú con varios archivos guardados recientemente. Pulsar sobre un archivo concreto hará que se abra en KWrite (si el archivo sigue guardado en el mismo sitio).
  • Guardar: Guarda el documento actual. Si ya se había guardado anteriormente este documento se sobreescribirá el anterior sin preguntar al usuario. Si es la primera vez que se guarda el documento aparecerá el diálogo (que se describe más adelante) guardar como.
  • Guardar como: Permite que un documento sea guardado con un nombre nuevo. Esto se hace a través del cuadro de diálogo de archivo descrito anteriormente en la sección Abrir de este archivo de ayuda.
  • Recargar: Recarga el archivo activo. Esta orden es práctica si otro programa o proceso ha cambiado el archivo mientras estaba abierto en KWrite.
  • Imprimir: Abre un diálogo de impresión sencillo que permite al usuario especificar qué, dónde y cómo imprimir.
  • Exportar como HTML: Exporta su archivo en formato HTML de forma que su documento pueda verse como una página web.
  • Cerrar: Cierra el archivo activo con esta orden. Si tiene cambios sin guardar, se le preguntará si desea guardar el archivo antes de cerrarlo.
  • Salir: Cerrará la ventana del editor, si tiene más de una instancia de KWrite en ejecución, a través de Nueva vista o de los elementos de menú Nueva ventana, éstas instancias no se cerrarán.


Menú Editar


(thumbnail)
Menú Editar

  • Deshacer: Se utiliza para eliminar o invertir la acción u operación más reciente.
  • Rehacer: Invertirá los cambios más recientes (si los hay) hechos utilizando Deshacer.
  • Cortar: Esta orden borra la selección actual y la coloca en el portapapeles. El portapapeles es una característica de KDE que funciona de forma transparente para proporcionar una forma de transferir datos entre aplicaciones.
  • Copiar: Copia el texto seleccionado al portapapeles de forma que pueda pegarse dónde se desee. El portapapeles es una característica de KDE que funciona de forma transparente para proporcionar una forma de transferir datos entre aplicaciones.
  • Copiar como HTML: Copia el texto seleccionado al portapapeles como HTML.
  • Pegar: Insertará el contenido del portapapeles en la posición del cursor. El portapapeles es la características de KDE que funciona de forma transparente para proporcionar una forma de transferir datos entre aplicaciones.
  • Seleccionar Todo: Seleccionará el documento completo. Ésto puede ser muy práctico para copiar el archivo completo a otra aplicación.
  • Deseleccionar: Deselecciona el texto seleccionado en el editor si existe.
  • Modo de selección de bloques: Cambia el modo de selección cuando el modo de selección sea «BLOQUE», puede realizar selecciones verticales, por ejemplo, seleccione las columnas 5 a 10 y las filas 9 a 15. La barra de estado mostrará el estado actual del modo de selección, es decir «NORM» o «BLK».
  • Modo Sobreescribir: Cambia entre los modos insertar/sobreescribir. Cuando el modo sea «insertar» insertará caracteres en la posición del cursor. Cuando el modo sea «sobreescribir», escribirá caracteres reemplazando los caracteres de la posición del cursor. La barra de estado mostrará el estado actual del modo sobreescribir, con «INS» o «SOB».
  • Buscar: Abre el diálogo buscar que se utiliza para especificar el Texto a buscar en el documento. Aparecerá un pequeño cuadro de texto para introducir el patrón de búsqueda que también puede introducirse a través del desplegable. Pulsando en la flecha situada al lado del desplegable se podrán utilizar otros modelos de búsqueda realizadas recientemente. Se pueden incluir otros parámetros para hacer la búsqueda más eficiente. Seleccionando Distinguir mayúsculas/minúsculas limitará las búsquedas a las entradas que coincidan también en mayúsculas y minúsculas para cada uno de los caracteres en el modelo de búsqueda. Buscar hacia atrás hace que la dirección de la búsqueda sea hacia arriba. La opción Texto seleccionado busca en el texto actualmente seleccionado. Marcar Sólo palabras completas evita que la búsqueda se pare en palabras que contengan el modelo buscado. La opción Desde el cursor inicia la búsqueda desde la posición del cursor en lugar de desde el principio.
  • Buscar siguiente: Repite la última operación de búsqueda, si existe, sin llamar al cuadro de diálogo de búsqueda.
  • Buscar anterior: Repite la última operación de búsqueda, si existe, sin llamar al cuadro de diálogo buscar, pero buscando en el documento hacia detrás en lugar de hacia delante.
  • Reemplazar: Abre el cuadro de diálogo reemplazar. El diálogo reemplazar es prácticamente idéntico al diálogo buscar mencionado anteriormente. Como características adicionales tiene un cuadro de texto desplegable Reemplazar con. Utilizando este diálogo el usuario puede especificar el texto que se debe encontrar y el texto con el que se debe reemplazar. La opción Preguntar si reemplazar hace que KWrite le pida confirmación al usuario antes de cada reemplazo.
  • Ir a la línea: Abre el cuadro de diálogo ir a la línea que se utiliza para hacer que el cursor salte a una línea en particular (especificada por el número) del documento. El número de línea se puede introducir directamente en el cuadro de texto o gráficamente pulsando sobre los botoncitos con las flechas arriba y abajo situados al lado del cuadro de texto. La flechita hacia arriba incrementará el número de línea y la flecha hacia abajo lo decrementará. También existe un control deslizador a la derecha del cuadro de texto que permitirá al usuario moverse a un punto del documento de manera similar.


Menú Ver

El menú Ver le permite administrar configuraciones específicas del editor activo, y administrar los marcos.


(thumbnail)
Menú Ver

  • Nueva ventana: Abre una nueva ventana con el mismo texto.
  • Ajuste de línea dinámico:Las líneas de texto se ajustarán en la vista del borde de la pantalla.
  • Mostrar números de líneas: Muestra u oculta los números de línea del documento visible en la parte izquierda del editor activo.


Menú Herramientas


(thumbnail)
Menú Herramientas

  • Modo de solo de lectura: Establece el modo de solo lectura para el documento actual. Esto evita que se añada texto o se modifique el formato en el documento.
  • Codificación: Puede sobreescribir la configuración predeterminada configurada en Preferencias → Configurar editor... en la pestaña Abrir/Guardar para asignar una codificación diferente para su documento actual. La codificación que asignó aquí solo será válida para su documento actual.
  • Ortografía: Inicia el programa de verificación ortográfica (un programa diseñado para ayudar al usuario a encontrar y corregir errores ortográficos). Pulsar sobre esta entrada iniciará la comprobación y saltará al cuadro de diálogo de verificación ortográfica a través del cual podrá controlar el proceso. Existen cuatro opciones alineadas verticalmente en el centro del cuadro de diálogo con sus correspondientes etiquetas en la parte izquierda.
  • Comprobar ortografía desde el cursor: Esto inicia el programa de corrección ortográfica pero comenzando en la posición actual del cursor en lugar de desde el inicio del documento.
  • Comprobar ortografía de la selección: Realiza la corrección ortográfica de la selección actual.
  • Sangrar: Incrementa el sangrado del párrafo un paso. El tamaño del paso dependerá de la configuración del sangrado.
  • Sangrado inverso: Reduce el sangrado del párrafo un paso. El tamaño del paso dependerá de la configuración del sangrado.
  • Limpiar sangrado: Elimina el sangrado para la selección actual o para la línea en la que se encuentre el cursor. Borrar el sangrado asegura que todo el texto seleccionado siga el modo de sangrado que haya elegido.
  • Alinear: Provoca la realineación de la línea actual o de las líneas seleccionadas utilizando el modo de sangrado y la configuración de sangrado del documento.
  • Mayúsculas: Cambia el texto seleccionado o la letra después del cursor a mayúsculas.
  • Minúsculas: Cambia el texto seleccionado o la letra después del cursor a minúsculas.
  • Capitalizar: Capitaliza el texto seleccionado o la palabra actual.
  • Unir líneas: Une las líneas seleccionadas, o la línea actual y la línea anterior con un espacio en blanco como separador. Se eliminarán los espacios en blanco sobrantes en las líneas afectadas.
  • Ajuste de línea del documento: Aplica el ajuste de línea estático en todo el documento. Esto significa que se iniciará automáticamente una nueva línea de texto cuando la línea exceda la longitud especificada por el ajuste de línea.


Menú Preferencias


(thumbnail)
Menú Preferencias

  • Barra de estado: Cuando está marcada, muestra una pequeña barra en la parte inferior del editor conteniendo información sobre el documento actual. Cuando no está marcada la barra de estado se ocultará.
  • Mostrar la barra de herramientas: Cuando está marcada, muestra una barra de herramientas que contiene botones para iniciar órdenes que se usan con cierta frecuencia. Si está desmarcada la barra de herramientas se ocultará.
  • Mostrar la ruta: Si está seleccionada, mostrará en la barra de título la ruta (su ubicación en el sistema de archivos) del documento actual. Si está desmarcada la ruta se ocultará.
  • Configurar editor: Este elemento de menú abre un diálogo a través del cual se pueden ajustar algunas configuraciones.
  • Configurar accesos rápidos: Muestra un cuadro de diálogo a través del cual puede cambiar los accesos rápidos. En la parte superior de la ventana que aparecerá podrá encontrar la listas de las órdenes (acciones) que pueden tener un acceso rápido. Debajo existen tres botones. El usuario puede escoger entre ninguna, predeterminado y personalizar (tenga en cuenta que los botones de radio sólo permite escoger una de las opciones. No obstante, la selección predeterminada sólo estará disponible para aquellas órdenes que en estos momentos tengan un acceso rápido «predeterminado»). Seleccionando la opción personalizar se activará un cuadro en el que podrá seleccionar una combinación de teclas. Por ejemplo, con la orden Acerca de KDE seleccionada en la ventana, el usuario podría seleccionar Ctrl y Alt, pulsando estos botones, y a continuación pulsar la letra K. Esto debería hacer que si mantiene pulsadas las teclas Ctrl y Alt y pulsa K (mientras esté utilizando KWrite) se mostrará el cuadro Acerca de KDE.
  • Configurar las barras de herramientas: Muestra una ventana de diálogo a través del cual se puede cambiar la configuración de la barra de herramientas. El usuario puede seleccionar qué botones de acceso rápido deberían aparecer en la barra de herramientas. La ventana listará en la parte izquierda las órdenes disponibles que se pueden colocar en la barra de herramientas. En la parte derecha se listarán las órdenes que ya están en la barra de herramientas. Un grupo de cuatro botones entre los dos cuadros permitirán manipular las selecciones. La flecha hacia la derecha coloca cualquier orden seleccionada en el panel derecho, es decir, se añadirá a la barra de herramientas. La flecha hacia la izquierda hace justo lo contrario, eliminando cualquier acción selccionada del cuadro de la derecha y por tanto de la barra de herramientas. Las flechas hacia arriba y abajo cambian la posición de una acción seleccionada en el cuadro derecho lo que hará cambiar su posición en la barra de herramientas.

Configuración de KWrite

Seleccionar Preferencias → Configurar editor muestra el cuadro de diálogo Configurar editor. Este diálogo puede utilizarse para cambiar una serie de configuraciones. Las configuraciones disponibles para cada categoría pueden variar de acuerdo con la categoría que el usuario seleccione en el listado vertical de la parte izquierda. A través de los tres botones del cuadro el usuario puede controlar el proceso.

Aspecto


(thumbnail)
Aspecto

  • Ajuste de línea dinámico: Si esta opción está marcada, las líneas de texto se ajustarán al borde de la pantalla.
  • Indicadores de ajuste de línea dinámicos: Elija cuándo se mostrarán los indicadores de ajuste de línea dinámico.
  • Alineación vertical del ajuste de línea dinámico con la profundidad de sangrado: Activa el inicio del ajuste de línea dinámico para que se alinee verticalmente al nivel de sangrado de la primera línea. Puede ayudarle a escribir código y marcas más legibles. Además, le permite configurar el ancho máximo de la pantalla, como un porcentaje, después del que las líneas ajustadas dinámicamente no se alinearán verticalmente. Por ejemplo, al 50%, a las líneas cuyos niveles de indentación sean mayores del 50% del ancho de la pantalla no se les aplicará la alineación vertical a las siguientes líneas ajustadas.

Bordes

  • Mostrar el borde de los iconos: Si está marcado, verá un borde de icono en la parte izquierda. El borde de icono muestra símbolos de marcadores.
  • Mostrar los números de líneas: Si está marcado, verá los números de línea en la parte izquierda.
  • Mostrar marcas en las barras de desplazamiento Si está marcada esta opción la vista actual mostrará marcas en la barra de desplazamiento vertical. Estas marcas por ejemplo, mostrarán los marcadores.

Avanzados

  • Mostrar líneas de sangrado: Si está marcada, el editor mostrará líneas verticales para ayudarle a identificar el sangrado de las líneas
Herramientas personales
Espacios de nombres

Variantes
Acciones
Navegación
Herramientas